https://www.acmicpc.net/problem/10828
문제
정수를 저장하는 스택을 구현한 다음, 입력으로 주어지는 명령을 처리하는 프로그램을 작성하시오.
명령은 총 다섯 가지이다.
- push X: 정수 X를 스택에 넣는 연산이다.
- pop: 스택에서 가장 위에 있는 정수를 빼고, 그 수를 출력한다. 만약 스택에 들어있는 정수가 없는 경우에는 -1을 출력한다.
- size: 스택에 들어있는 정수의 개수를 출력한다.
- empty: 스택이 비어있으면 1, 아니면 0을 출력한다.
- top: 스택의 가장 위에 있는 정수를 출력한다. 만약 스택에 들어있는 정수가 없는 경우에는 -1을 출력한다.
입력
첫째 줄에 주어지는 명령의 수 N (1 ≤ N ≤ 10,000)이 주어진다. 둘째 줄부터 N개의 줄에는 명령이 하나씩 주어진다. 주어지는 정수는 1보다 크거나 같고, 100,000보다 작거나 같다. 문제에 나와있지 않은 명령이 주어지는 경우는 없다.
출력
출력해야 하는 명령이 주어질 때마다, 한 줄에 하나씩 출력한다.
예제 입력 1 복사
14
push 1
push 2
top
size
empty
pop
pop
pop
size
empty
pop
push 3
empty
top
예제 출력 1 복사
2
2
0
2
1
-1
0
1
-1
0
3
풀이
NOTE
String.valueOf
형 변환을 할 때 사용된다.
파라미터가 null 이면 문자열 null을 만들어서 담는다.
예제)
int num = 100;
String string = String.valueOf(var);
System.out.println(string);
// 결과 100
import java.io.*;
import java.nio.Buffer;
class Stack { //함수를 만들어준다
private int top;
private int stackArr[];
public Stack(int size) {
this.top = -1;
this.stackArr = new int[size];
}
public void push(int x) {
this.stackArr[++top] = x;
}
public int pop() {
if (top == -1) return -1;
return this.stackArr[top--];
}
public int size() {
return this.top + 1;
}
public int empty() {
if (this.top == -1) {
return 1;
} else return 0;
}
public int top() {
if (this.top == -1) return -1;
return this.stackArr[top];
}
}
public class Main {
public static void main(String[] args) throws IOException {
BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
BufferedWriter bw = new BufferedWriter(new OutputStreamWriter(System.out));
int N = Integer.parseInt(br.readLine());
Stack stack = new Stack(N);
for (int i = 0; i < N; i++) {
String input = br.readLine();
if (input.contains("push")) {
String[] split = input.split(" ");
stack.push(Integer.parseInt(split[1]));
} else if (input.contains("pop")) {
bw.write(String.valueOf(stack.pop()) + "\n");
} else if (input.contains("size")) {
bw.write(String.valueOf(stack.size()) + "\n");
} else if (input.contains("empty")) {
bw.write(String.valueOf(stack.empty()) + "\n");
} else if (input.contains("top")) {
bw.write(String.valueOf(stack.top()) + "\n");
}
}
bw.flush();
bw.close();
br.close();
}
}
|
cs |
'코딩 문제 > 백준 [ Java ]' 카테고리의 다른 글
[ 백준 2583 / Java ] 영역 구하기 (0) | 2022.07.14 |
---|---|
[ 백준 2468 / Java ] 안전 영역 (JAVA) (0) | 2022.07.11 |
[ 백준 11724 / Java ] 연결 요소의 개수 (0) | 2022.07.06 |
[ 백준 7568 / Java ] 덩치 (JAVA) (0) | 2022.07.05 |
[ 백준 2941 / Java ] 크로아티아 알파벳 (0) | 2022.07.01 |
댓글